Command 'qmake -spec macx-g++ ' not available
New here? Learn about Bountify and follow @bountify to get notified of new bounties! x

I'm getting this error and I'm not sure what to make of it. If you could tell me some commands to run to debug this and get my bundler going, I'd appreciate it!

I'll be glad to post stdout as you tell me what commands to run.

Installing opennebula 4.10.1

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    /Users/akshatpradhan/.rbenv/versions/2.1.2/bin/ruby extconf.rb
Command 'qmake -spec macx-g++ ' not available

Makefile not found

Gem files will remain installed in /Users/akshatpradhan/.rbenv/versions/2.1.2/lib/ruby/gems/2.1.0/gems/capybara-webkit-1.3.1 for inspection.
Results logged to /Users/akshatpradhan/.rbenv/versions/2.1.2/lib/ruby/gems/2.1.0/extensions/x86_64-darwin-13/2.1.0-static/capybara-webkit-1.3.1/gem_make.out
Installing fog 1.25.0
An error occurred while installing capybara-webkit (1.3.1), and Bundler cannot
continue.
Make sure that `gem install capybara-webkit -v '1.3.1'` succeeds before
bundling.
  compliance_chimp git:(home_page) qmake
zsh: command not found: qmake
  compliance_chimp git:(home_page) brew search qmake
No formula found for "qmake".
Searching pull requests...
Closed pull requests:
qmake gets installed by QT (https://github.com/Homebrew/homebrew/pull/31336)
Added patch for XCode4 support for qmake. (https://github.com/Homebrew/homebrew/pull/10475)
PyQT5.rb Specify qt5 version of qmake. (https://github.com/Homebrew/homebrew/pull/27059)
PyQt: patch to fix handling of qmake inline comments (https://github.com/Homebrew/homebrew/pull/25225)
qscintilla2: define 10.9 qmake make spec for lib and python module (https://github.com/Homebrew/homebrew/pull/25882)

I wonder if I could sneak a quick question. When I run rake db:migrate, I get this error ArgumentError: No APPLICATION_ID provided, please set :application_id.

  compliance_chimp git:(home_page) rake db:migrate
WARNING: Use strings for Figaro configuration. ["admin", "user", "VIP"] was converted to "[\"admin\", \"user\", \"VIP\"]".
rake aborted!
ArgumentError: No APPLICATION_ID provided, please set :application_id
/Users/akshatpradhan/Sites/compliance_chimp/config/initializers/algoliasearch.rb:1:in `<top (required)>'
/Users/akshatpradhan/Sites/compliance_chimp/config/environment.rb:5:in `<top (required)>'
Tasks: TOP => db:migrate => environment
(See full trace by running task with --trace)
could you get the full stack trace? also, what repo and branch is the compliance_chimp from? I'm looking at repos but can't find any with algoliasearch.rb
julianobs over 4 years ago
awarded to julianobs

Crowdsource coding tasks.

2 Solutions


Do you have qmake installed? There is a nice set of instructions here.

From the solution by @juliannobs, qmake seems to be bundled with qt so you can just install homebrew and execute brew install qt.
alex over 4 years ago
Winning solution

Could this be a solution?

Command 'qmake -spec macx-g++' not available #521

From the link:
A simple brew install qt should do the trick.

I think this is it, I'm running bundler now to see if I have any more errors, thank you
akshatpradhan over 4 years ago
glad to help =]
julianobs over 4 years ago
I updated the question a bit and I was wondering if I could sneak one more? I'm not sure if you're familiar with Rails.
akshatpradhan over 4 years ago
I figured it out. I'm using figaro and for some reason my config/application.yml is gone. All my private keys are in there for my development environment. Good practice to rotate all the keys though so I'm ok with having to generate new keys for api's I use.
akshatpradhan over 4 years ago
View Timeline